[CrackMonkey] The EXCITING CONCLUSION.
nick at zork.net
Sat Dec 9 10:02:28 PST 2000
Far removed from the squalid villiage below, they fight their
petty battles over power and money...
----- Forwarded message from Christian Holmboe <spotty at codefactory.se> -----
On Fri, 8 Dec 2000, Nick Moffitt wrote:
> begin Christian Holmboe quotation:
> > First off I'd like to thank you for your research on the subject :)
> As research projects go, this has definitely been a surreal
> one. :)
> I found that "cunit" is also a term among loggers for 100
> cubic feet of wood. Apparently it's been a long-standing joke among
> them as well. (the name comes from the fact that it's a C-unit (a
> unit of a hundred) as well as a unit in cubic feet)
> > keeping to tradition will leave us with different capitalizations :
> > CUnit or cUnit
> > I think CUnit is taken, so it boils down to 'cUnit'.
> Hmmm. Is CUnit the win32-centric one?
Yes, i guess so. The CUnit I was thinking of (and the only one I
know of) is Andrew Wall's creation posted on
http://www.xprogramming.com/software.htm. This is actually the only place
Ive seen it mentioned and there is no reference to a 'official site' in
the distrubution package. I get the feel of "public domian
snippet" rather than a supported test framework. So it might not be a
problem if Id like to adopt the name 'CUnit', but I like cUnit better.
> > Do you think cUnit would do the trick? It's by far less obvious
> > even if keeping to tradition will leave the letters in there,
> > preventing us to rid the problem completely as CTest or CUnitTest
> > would.
> I like it. It solves the problem of providing a visually
> obvious word-break, while staying true to the naming scheme. In
> addition, it meets many people's sense of C aesthetics in that most
> functions should have namesLikeThis(). It is, after all, the function
> names that users will see most often.
My thoughts exactly.
> > My vote is on cUnit, but I would like to have a second opinion from
> > you.
> For what it's worth, it has my vote as well. Not that my
> country has a good history of counting votes accurately :)
lol, you've had some good practice thou lately.. :) I can take it upon me
to count the votes if you dont feel up to it.. :)
Thank you both for your time and thoughts. It seems that cunit -> cUnit.
(not that big of a change if you look at the words side by side.. :)
Christian Holmboe spotty at codefactory dot se
CodeFactory AB http://www.codefactory.se/
Office: +46 (0)90 - 71 86 10 Cell: +46 (0)70 - 587 90 49
----- End forwarded message -----
CrackMonkey.Org - Non-sequitur arguments and ad-hominem personal attacks
Pigdog.Org - The Online Handbook for Bad People of the Future
You are not entitled to your opinions.
More information about the Crackmonkey